summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33a63e45..b3118d5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -204,6 +204,7 @@ fm_run_hook(fm-userconfig-src)
if(CMAKE_COMPILER_IS_GNUCXX)
add_compile_options(-Wno-float-equal)
+ add_compile_options(-Wreturn-type -Werror=return-type)
endif()
if (CMAKE_CXX_COMPILER_ID MATCHES "Clang$")