summaryrefslogtreecommitdiffhomepage
path: root/serialize/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'serialize/CMakeLists.txt')
-rw-r--r--serialize/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/serialize/CMakeLists.txt b/serialize/CMakeLists.txt
new file mode 100644
index 00000000..65b63174
--- /dev/null
+++ b/serialize/CMakeLists.txt
@@ -0,0 +1,13 @@
+set(self floormat-serialize)
+file(GLOB sources "*.cpp" CONFIGURE_ARGS)
+add_library(${self} STATIC "${sources}")
+target_link_libraries(
+ ${self} PUBLIC
+ floormat-loader
+ floormat
+ Magnum::Magnum
+ nlohmann_json::nlohmann_json
+)
+if(FLOORMAT_PRECOMPILED-HEADERS)
+ target_precompile_headers(${self} PRIVATE precomp.hpp)
+endif()