summaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index eae3ffd5..11e3fb09 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -21,3 +21,11 @@ if(FLOORMAT_PRECOMPILED-HEADERS)
target_precompile_headers(${self}_o PRIVATE precomp.hpp)
endif()
install(TARGETS ${self} RUNTIME DESTINATION bin)
+
+set(save-dir "${CMAKE_BINARY_DIR}/test/save")
+file(REMOVE_RECURSE "${save-dir}")
+file(MAKE_DIRECTORY "${save-dir}")
+file(GLOB saves "save/*.dat" CONFIGURE_ARGS)
+foreach(file ${saves})
+ configure_file("${file}" "${save-dir}" COPYONLY)
+endforeach()