summaryrefslogtreecommitdiffhomepage
path: root/eigen/blas/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'eigen/blas/CMakeLists.txt')
-rw-r--r--eigen/blas/CMakeLists.txt37
1 files changed, 17 insertions, 20 deletions
diff --git a/eigen/blas/CMakeLists.txt b/eigen/blas/CMakeLists.txt
index a9bc051..9887d58 100644
--- a/eigen/blas/CMakeLists.txt
+++ b/eigen/blas/CMakeLists.txt
@@ -14,23 +14,18 @@ endif()
add_custom_target(blas)
-set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp xerbla.cpp)
-
-if(EIGEN_Fortran_COMPILER_WORKS)
-
-set(EigenBlas_SRCS ${EigenBlas_SRCS}
- complexdots.f
- srotm.f srotmg.f drotm.f drotmg.f
- lsame.f dspmv.f ssbmv.f
- chbmv.f sspmv.f
- zhbmv.f chpmv.f dsbmv.f
- zhpmv.f
- dtbmv.f stbmv.f ctbmv.f ztbmv.f
-)
+set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp xerbla.cpp
+ f2c/srotm.c f2c/srotmg.c f2c/drotm.c f2c/drotmg.c
+ f2c/lsame.c f2c/dspmv.c f2c/ssbmv.c f2c/chbmv.c
+ f2c/sspmv.c f2c/zhbmv.c f2c/chpmv.c f2c/dsbmv.c
+ f2c/zhpmv.c f2c/dtbmv.c f2c/stbmv.c f2c/ctbmv.c
+ f2c/ztbmv.c f2c/d_cnjg.c f2c/r_cnjg.c
+ )
+
+if (EIGEN_Fortran_COMPILER_WORKS)
+ set(EigenBlas_SRCS ${EigenBlas_SRCS} fortran/complexdots.f)
else()
-
-message(WARNING " No fortran compiler has been detected, the blas build will be incomplete.")
-
+ set(EigenBlas_SRCS ${EigenBlas_SRCS} f2c/complexdots.c)
endif()
add_library(eigen_blas_static ${EigenBlas_SRCS})
@@ -50,10 +45,12 @@ install(TARGETS eigen_blas eigen_blas_static
if(EIGEN_Fortran_COMPILER_WORKS)
-if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
- add_subdirectory(testing) # can't do EXCLUDE_FROM_ALL here, breaks CTest
-else()
- add_subdirectory(testing EXCLUDE_FROM_ALL)
+if(BUILD_TESTING)
+ if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+ add_subdirectory(testing) # can't do EXCLUDE_FROM_ALL here, breaks CTest
+ else()
+ add_subdirectory(testing EXCLUDE_FROM_ALL)
+ endif()
endif()
endif()