summaryrefslogtreecommitdiffhomepage
path: root/eigen/doc/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'eigen/doc/examples/CMakeLists.txt')
-rw-r--r--eigen/doc/examples/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/eigen/doc/examples/CMakeLists.txt b/eigen/doc/examples/CMakeLists.txt
index 08cf8ef..f7a1905 100644
--- a/eigen/doc/examples/CMakeLists.txt
+++ b/eigen/doc/examples/CMakeLists.txt
@@ -14,3 +14,8 @@ foreach(example_src ${examples_SRCS})
)
add_dependencies(all_examples ${example})
endforeach(example_src)
+
+check_cxx_compiler_flag("-std=c++11" EIGEN_COMPILER_SUPPORT_CPP11)
+if(EIGEN_COMPILER_SUPPORT_CPP11)
+ei_add_target_property(nullary_indexing COMPILE_FLAGS "-std=c++11")
+endif() \ No newline at end of file