summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-09-17 20:24:25 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-09-17 20:24:25 +0200
commitf159fc2b84d2c7139c348d167c7491fb43fb7e5e (patch)
tree40e8bf94413991626116e59d9a127542d38ac6e6 /CMakeLists.txt
parent5066045c9ba532aae151a2176a0afdb8bd2fcdfc (diff)
proto-wine: fix warnings, dependencies, reformat
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc734e43..6385f04d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -416,6 +416,9 @@ endif()
if(NOT SDK_WINE_NO_WRAPPER)
add_custom_command(
OUTPUT opentrack-wrapper-wine.exe.so
+ DEPENDS "${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-main.cxx"
+ "${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-posix.cxx"
+ "${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-windows.cxx"
COMMAND "${SDK_WINE_PREFIX}/bin/wineg++" -g -O2 -m32 -o
opentrack-wrapper-wine.exe -I "${CMAKE_SOURCE_DIR}"
"${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-main.cxx"
@@ -423,6 +426,7 @@ endif()
"${CMAKE_SOURCE_DIR}/ftnoir_protocol_wine/opentrack-wrapper-wine-windows.cxx"
-lrt)
add_custom_target(wine-wrapper ALL DEPENDS opentrack-wrapper-wine.exe.so)
+ add_dependencies(wine-wrapper opentrack-compat opentrack-proto-wine)
endif()
endif()