summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-09-14 19:30:08 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-09-14 19:30:08 +0200
commit98a70e0e80e82f8bb0205d106c745cfa545e21a0 (patch)
tree8c60478bcf17e0d9ee88e19a76a280aedb35ef9a /CMakeLists.txt
parent2516f604e6d6728a994d607230ff22550019634c (diff)
Init X11 threads on Q_OS_UNIX
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c7b1389..6e5b6978 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -492,6 +492,8 @@ endif()
add_executable(opentrack ${opentrack-win32-executable} ${opentrack-bin-c} ${opentrack-bin-moc} ${opentrack-bin-uih} ${opentrack-bin-rcc})
if(WIN32)
target_link_libraries(opentrack "${CMAKE_SOURCE_DIR}/dinput/dinput8.lib" "${CMAKE_SOURCE_DIR}/dinput/dxguid.lib" "${CMAKE_SOURCE_DIR}/dinput/strmiids.lib" winmm)
+ else()
+ target_link_libraries(opentrack X11)
endif()
if(MSVC)
SET_TARGET_PROPERTIES(opentrack PROPERTIES LINK_FLAGS "/ENTRY:mainCRTStartup")