summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-11-24 07:05:13 +0100
committerStanislaw Halik <sthalik@misaki.pl>2013-11-24 07:05:13 +0100
commitd86ae694c29b6652ff51986a02e549be077a8dbc (patch)
treea25b748da9f4e6be5bb838c3e0b380b712da5c91 /CMakeLists.txt
parent6cd2332a806013108322776d696fe34429dcd815 (diff)
Disable auto-export to fix FSUIPC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b0975ae..12c4cee0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -433,6 +433,8 @@ if(WIN32)
target_link_libraries(opentrack-proto-fsuipc ${MY_QT_LIBS} "${SDK_FSUIPC}/FSUIPC_User.lib")
if(MSVC)
set_target_properties(opentrack-proto-fsuipc PROPERTIES LINK_FLAGS "/NODEFAULTLIB:libc")
+ else()
+ set_target_properties(opentrack-proto-fsuipc PROPERTIES LINK_FLAGS "-Wl,--exclude-all-symbols")
endif()
endif()