summaryrefslogtreecommitdiffhomepage
path: root/compat/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2017-06-10 12:45:01 +0200
committerStanislaw Halik <sthalik@misaki.pl>2017-06-10 12:45:01 +0200
commitb67d81563718bd1f773f9e586b04b285e45b1208 (patch)
treef591d180832dd8ca31e7a76c08c244f6cd16c2c3 /compat/CMakeLists.txt
parente3cf9b75b24ce6b202f33f2efc9de41e7c2aa01e (diff)
compat/timer-resolution: we want higher timer resolution
Windows scheduler performs badly with 1000 Hz.
Diffstat (limited to 'compat/CMakeLists.txt')
-rw-r--r--compat/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/compat/CMakeLists.txt b/compat/CMakeLists.txt
index 33cb02bd..7e5dd4cd 100644
--- a/compat/CMakeLists.txt
+++ b/compat/CMakeLists.txt
@@ -4,6 +4,10 @@ if(NOT WIN32 AND NOT APPLE)
target_link_libraries(opentrack-compat rt)
endif()
+if(WIN32)
+ target_link_libraries(opentrack-compat winmm)
+endif()
+
if(CMAKE_COMPILER_IS_GNUCXX)
otr_prop(SOURCE nan.cpp COMPILE_FLAGS "-fno-lto -fno-fast-math -fno-finite-math-only -O0")
endif()