summaryrefslogtreecommitdiffhomepage
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
index cb5e2bdc..db2f0b9e 100644
--- a/gui/CMakeLists.txt
+++ b/gui/CMakeLists.txt
@@ -5,7 +5,6 @@ target_link_libraries(${self}
opentrack-logic
opentrack-spline
opentrack-pose-widget
- opentrack-version
)
# for process detector
@@ -15,3 +14,7 @@ elseif(LINUX)
otr_pkgconfig(${self} libprocps)
endif()
+if(NOT APPLE AND NOT WIN32)
+ target_compile_definitions(${self} PRIVATE -DOTR_X11_THREADS)
+ otr_pkgconfig(${self} x11)
+endif()