summaryrefslogtreecommitdiffhomepage
path: root/main-window/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'main-window/CMakeLists.txt')
-rw-r--r--main-window/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/main-window/CMakeLists.txt b/main-window/CMakeLists.txt
index f69080f1..c9228536 100644
--- a/main-window/CMakeLists.txt
+++ b/main-window/CMakeLists.txt
@@ -1,4 +1,6 @@
-otr_module(main-window BIN NO-INSTALL)
-foreach(k user-interface logic pose-widget migration spline)
- target_link_libraries(${self} opentrack-${k})
-endforeach()
+if(opentrack_maintainer-mode)
+ otr_module(main-window BIN NO-INSTALL)
+ foreach(k user-interface logic pose-widget migration spline)
+ target_link_libraries(${self} opentrack-${k})
+ endforeach()
+endif()