summaryrefslogtreecommitdiffhomepage
path: root/qxt-mini/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qxt-mini/CMakeLists.txt')
-rw-r--r--qxt-mini/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/qxt-mini/CMakeLists.txt b/qxt-mini/CMakeLists.txt
index 487b48d0..f355b943 100644
--- a/qxt-mini/CMakeLists.txt
+++ b/qxt-mini/CMakeLists.txt
@@ -2,9 +2,7 @@ if(UNIX OR APPLE)
set(self opentrack-qxt-mini)
otr_module(qxt-mini NO-COMPAT BIN)
if(APPLE)
- set_property(TARGET ${self}
- APPEND_STRING PROPERTY
- LINK_FLAGS " -framework Carbon -framework CoreFoundation ")
+ target_link_options(${self} PUBLIC -framework Carbon -framework CoreFoundation)
else()
otr_pkgconfig(${self} x11 xcb xproto)
endif()