summaryrefslogtreecommitdiffhomepage
path: root/tracker-rs/rs_impl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tracker-rs/rs_impl/CMakeLists.txt')
-rw-r--r--tracker-rs/rs_impl/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tracker-rs/rs_impl/CMakeLists.txt b/tracker-rs/rs_impl/CMakeLists.txt
new file mode 100644
index 00000000..10a71537
--- /dev/null
+++ b/tracker-rs/rs_impl/CMakeLists.txt
@@ -0,0 +1,6 @@
+if(WIN32)
+ opentrack_boilerplate(opentrack-tracker-rs-impl STATIC NO-QT SOURCES "${SDK_REALSENSE}/opensource/src/libpxc/libpxc.cpp")
+ target_compile_definitions(opentrack-tracker-rs-impl PRIVATE -DUNICODE -D_UNICODE -DEXPORT_RS_IMPL)
+ target_include_directories(opentrack-tracker-rs-impl PRIVATE SYSTEM "${SDK_REALSENSE}/include")
+ target_link_libraries(opentrack-tracker-rs-impl advapi32)
+endif()