summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-20 23:26:44 +0200
committerStanislaw Halik <sthalik@misaki.pl>2022-10-20 23:26:44 +0200
commit3c4a9458dd06868fa9bbaab1742ef91816bcd8ac (patch)
tree7dcfc2f99b0f35f8476ab5946f4c68217037b1f2 /CMakeLists.txt
parent06a625e3fc012218384078811cd2fb483d3abf16 (diff)
uppercase build type at more occasions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7447b2a4..842808d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,7 @@ endif()
if(CMAKE_BUILD_TYPE STREQUAL "")
set(CMAKE_BUILD_TYPE "RELEASE" CACHE STRING "" FORCE)
endif()
+string(TOUPPER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE)
function(sets type)
set(i 0)
@@ -97,6 +98,7 @@ set_directory_properties(PROPERTIES INTERFACE_CORRADE_CXX_STANDARD ${CMAKE_CXX_S
if(NOT "$ENV{FLOORMAT_NO_USERCONFIG}" AND NOT FLOORMAT_NO_USERCONFIG)
fm_load_userconfig()
+ string(TOUPPER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE)
endif()
add_subdirectory(external)