summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-10-17 00:49:05 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-10-17 00:49:05 +0200
commit3e819f9bde8e156a2a7a17312a6f4a941021a19e (patch)
treec86b8589cd3cc85c1072face33b2dfbf2bbecec4 /CMakeLists.txt
parent1c4d7b84544ef44ce43f76b42ecdf389015de4e6 (diff)
cccc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a6754fae..a206cbe8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -231,6 +231,11 @@ function(fm_add_install_executable self)
)
install(FILES "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${exe}.debug" DESTINATION bin)
install(FILES "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${exe}.nodebug" RENAME "${exe}" DESTINATION bin)
+ else()
+ install(FILES "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${exe}" DESTINATION bin)
+ if(MSVC)
+ install(FILES $<TARGET_PDB_FILE:${self}> DESTINATION bin)
+ endif()
endif()
endfunction()