summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-10-11 10:33:07 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-10-11 10:33:07 +0200
commit67a2d708dc4b29da8ae0bf039e25081e87c8d55a (patch)
tree05e7cb34317e0a2d0ce8a09eb147e0a705b60147 /CMakeLists.txt
parent351932d93aab921bf30fa1d1add4eb6bb3272fb6 (diff)
cmake: kill -Wfloat-equal
It crashes clang 16.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b58b976..c52a2a2c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -135,6 +135,7 @@ if(MSVC)
add_link_options(-HIGHENTROPYVA)
endif()
else()
+ add_compile_options(-Wno-float-equal)
if(NOT WIN32)
add_compile_options($<$<COMPILE_LANGUAGE:CXX>:-fuse-cxa-atexit>)
endif()
@@ -178,6 +179,10 @@ endif()
fm_run_hook(fm-userconfig-src)
+if(CMAKE_COMPILER_IS_GNUCXX)
+ add_compile_options(-Wno-float-equal)
+endif()
+
if (CMAKE_CXX_COMPILER_ID MATCHES "Clang$")
add_definitions(-D_LIBCPP_REMOVE_TRANSITIVE_INCLUDES)
add_compile_options(-Wno-shift-op-parentheses)