summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-21 01:00:54 +0200
committerStanislaw Halik <sthalik@misaki.pl>2022-10-21 01:00:54 +0200
commit718346dbb91afab2d71f71683400d71bcaf6ee7c (patch)
tree14a92c000804abdba4acea19167e2846e0f5cb3c /CMakeLists.txt
parent21b306f204a8adfd4bed177914d3e6ce955d58e3 (diff)
fix corrade resource dtor not running
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 842808d1..924170f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -84,6 +84,8 @@ if(MSVC)
if(CMAKE_SIZEOF_VOID_P GREATER_EQUAL 8)
add_link_options(-HIGHENTROPYVA)
endif()
+else()
+ add_compile_options(-fuse-cxa-atexit)
endif()
if(CMAKE_CXX_COMPILER_ID MATCHES "Clang$")