summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-10-07 02:52:13 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-10-07 02:52:13 +0200
commit7f43ef4f91f961d14df62bec60bea3f7092c13b7 (patch)
treea1cbb4da6b683d0f8f8c828af0b2371e127bac84 /CMakeLists.txt
parent6d9a1ee9abffafe8842e03bc9daeba6cf7ec4048 (diff)
fix osx
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb64dc2f..052b5217 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -147,7 +147,7 @@ else()
endif()
endif()
-if(CMAKE_CXX_COMPILER_ID STREQUAL "AppleClang" OR CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+if(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
add_compile_definitions($<$<COMPILE_LANGUAGE:CXX>:$<$<CONFIG:DEBUG,Debug>:_LIBCPP_ENABLE_ASSERTIONS>>)
add_compile_options(-Wno-reserved-macro-identifier)
add_compile_options($<$<COMPILE_LANGUAGE:CXX>:-Wno-ambiguous-reversed-operator>)