summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-31 15:29:40 +0100
committerStanislaw Halik <sthalik@misaki.pl>2022-10-31 15:29:40 +0100
commit870d87b3b93d34207301c0b3fb084b275599dcb5 (patch)
tree5dcfe013b0aaa70d27e786259e87dac9a526a6cd /CMakeLists.txt
parentf2c0a9ec2fb4f51c0914c193a1600ca37ef01dcd (diff)
a
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46f9376c..25e54528 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,7 +100,6 @@ else()
endif()
if(CMAKE_CXX_COMPILER_ID MATCHES "Clang$")
-
add_compile_options(-Wno-reserved-macro-identifier)
endif()
@@ -121,6 +120,9 @@ if(MSVC)
add_definitions(/FI"compat/prelude.hpp")
else()
add_definitions(-include compat/prelude.hpp)
+ if(CMAKE_CXX_COMPILER_ID MATCHES "Clang$")
+ add_compile_options(-Wimplicit-fallthrough -Werror=implicit-fallthrough)
+ endif()
endif()
add_definitions(