summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-19 08:22:35 +0200
committerStanislaw Halik <sthalik@misaki.pl>2022-10-19 08:24:42 +0200
commitd70ff70b7d5a259572f7f641ea754f799bda3ea1 (patch)
tree7e19550f24fd0afa6f9de3cebb6b6c396f138126 /CMakeLists.txt
parente87062c5ed866710819a56859f430cad5cfed26e (diff)
some more build shenanigans
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb4e9922..c3d64102 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -123,14 +123,13 @@ sets(BOOL
MAGNUM_WITH_BULLET OFF
MAGNUM_WITH_DART OFF
- MAGNUM_WITH_EIGEN ON
- MAGNUM_WITH_GLM ON
+ MAGNUM_WITH_EIGEN OFF
+ MAGNUM_WITH_GLM OFF
MAGNUM_WITH_IMGUI ON
)
sets(BOOL
- SDL_SHARED ON
- SDL_STATIC OFF
+ SDL_ASSERTIONS release
SDL_3DNOW OFF
SDL_ALTIVEC OFF
@@ -219,6 +218,14 @@ else()
add_definitions(-include compat/prelude.hpp)
endif()
+if(MSVC)
+ add_compile_options(-W4)
+else()
+ add_compile_options(-Wall -Wextra -Wpedantic -Wno-old-style-cast -Wno-padded -Wno-ignored-attributes)
+ add_compile_options(-fcolor-diagnostics)
+ add_compile_options(-ferror-limit=5)
+endif()
+
add_subdirectory(src)
add_subdirectory(draw)
add_subdirectory(main)