summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-08-27 15:44:39 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-08-27 17:57:30 +0200
commit405c0c4214c48908d8203a8f4d911289211eb909 (patch)
treeac77153e2c07be81a89d708083743ae8f6932e83 /CMakeLists.txt
parent364155032c228342e853c8f1661fea0c57f11c15 (diff)
cmake: kill precompiled headers
They only help by 5% at best. Not worth the side effects.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c87871d..c84031cd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -181,7 +181,7 @@ if (CMAKE_CXX_COMPILER_ID MATCHES "Clang$")
add_definitions(-D_LIBCPP_REMOVE_TRANSITIVE_INCLUDES)
add_compile_options(-Wno-shift-op-parentheses)
elseif(CMAKE_COMPILER_IS_GNUCXX)
- add_compile_options(-Wno-subobject-linkage -Wno-parentheses)
+ add_compile_options(-Wno-subobject-linkage -Wno-parentheses -Wno-overloaded-virtual)
endif()
include_directories(.)