summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-10-06 19:29:28 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-10-06 19:31:18 +0200
commit41f8fe4e55a3b0f2e471959374ba36314e19edc0 (patch)
tree362982ad2b05427121d24fc9cd99360603bc8796 /CMakeLists.txt
parent5fe82a0a598331ca7b1bb5eea0286c09c4718981 (diff)
a
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0f83051b..fb64dc2f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -151,6 +151,8 @@ if(CMAKE_CXX_COMPILER_ID STREQUAL "AppleClang" OR CMAKE_CXX_COMPILER_ID STREQUAL
add_compile_definitions($<$<COMPILE_LANGUAGE:CXX>:$<$<CONFIG:DEBUG,Debug>:_LIBCPP_ENABLE_ASSERTIONS>>)
add_compile_options(-Wno-reserved-macro-identifier)
add_compile_options($<$<COMPILE_LANGUAGE:CXX>:-Wno-ambiguous-reversed-operator>)
+ add_compile_options(-fmodules)
+ add_link_options(-fmodules)
endif()
set_directory_properties(PROPERTIES CORRADE_USE_PEDANTIC_FLAGS OFF)