summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-10-17 11:51:09 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-10-17 11:51:09 +0200
commit88351e660bfd3dc0ce1287266eb41e10956e0e12 (patch)
treea4134db51f8504f1030a22831fbdd97b650df259 /CMakeLists.txt
parent3907f9b7dd425b3886a9b156d157c324cbf6196d (diff)
fix ci silent failure
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a206cbe8..33a63e45 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -230,9 +230,9 @@ function(fm_add_install_executable self)
WORKING_DIRECTORY "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}"
)
install(FILES "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${exe}.debug" DESTINATION bin)
- install(FILES "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${exe}.nodebug" RENAME "${exe}" DESTINATION bin)
+ install(PROGRAMS "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${exe}.nodebug" RENAME "${exe}" DESTINATION bin)
else()
- install(FILES "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${exe}" DESTINATION bin)
+ install(PROGRAMS "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${exe}" DESTINATION bin)
if(MSVC)
install(FILES $<TARGET_PDB_FILE:${self}> DESTINATION bin)
endif()