summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-11-01 16:35:08 +0100
committerStanislaw Halik <sthalik@misaki.pl>2022-11-01 16:35:08 +0100
commita7cfef3c3a0f1cadfd8dcfb142fbfa26ef03b413 (patch)
treebbc7c3a7e577b54d371428ec1e3cb9684bc7206e /CMakeLists.txt
parent704e9bd3ac58484a5209e186798076f1cbd432ef (diff)
cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 25e54528..e08dcc93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -89,7 +89,8 @@ if(MSVC)
add_compile_options(
#-wd4244 # warning C4244: 'argument': conversion from 'int' to 'float', possible loss of data
#-wd4251 # warning C4251: 't::f': class 'x' needs to have dll-interface to be used by clients of class 'y'
- -wd4456 # warning C4456: declaration of 'x' hides previous local declaration
+ -wd4456 # warning C4456: declaration of 'x' hides previous local declaration
+ -wd4458 # warning C4458: declaration of 'keys' hides class member
)
add_definitions(-utf-8)
if(CMAKE_SIZEOF_VOID_P GREATER_EQUAL 8)
@@ -97,6 +98,7 @@ if(MSVC)
endif()
else()
add_compile_options(-fuse-cxa-atexit)
+ add_compile_options(-fno-rtti)
endif()
if(CMAKE_CXX_COMPILER_ID MATCHES "Clang$")
@@ -123,6 +125,9 @@ else()
if(CMAKE_CXX_COMPILER_ID MATCHES "Clang$")
add_compile_options(-Wimplicit-fallthrough -Werror=implicit-fallthrough)
endif()
+ if(NOT APPLE AND NOT WIN32)
+ add_compile_options(-fno-plt)
+ endif()
endif()
add_definitions(