summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-10-20 12:33:00 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-10-20 12:33:00 +0200
commit275cb79a1857fff08ce1b642bbfab6d7377bcaef (patch)
treeb8671ed206fc27d4762779cf64113ef7d9ce8fd9 /CMakeLists.txt
parent5be116ea43231c747f09c4d43a75d45984b54a66 (diff)
aa
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33a63e45..b3118d5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -204,6 +204,7 @@ fm_run_hook(fm-userconfig-src)
if(CMAKE_COMPILER_IS_GNUCXX)
add_compile_options(-Wno-float-equal)
+ add_compile_options(-Wreturn-type -Werror=return-type)
endif()
if (CMAKE_CXX_COMPILER_ID MATCHES "Clang$")