summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-22 17:07:14 +0200
committerStanislaw Halik <sthalik@misaki.pl>2022-10-22 18:09:19 +0200
commit57b50fb3c629e024f6cfa202ba9c6eef37856f1c (patch)
tree8d6f02b372f538f3c9271566195b9f49e93248c6 /CMakeLists.txt
parent105740b8748315243a9f9c90fd252e132e5e741b (diff)
disable more imgui obsolete stuff
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94e56c5e..a9810a0e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,6 +112,11 @@ else()
add_definitions(-include compat/prelude.hpp)
endif()
+add_definitions(
+ -DIMGUI_DISABLE_OBSOLETE_FUNCTIONS
+ -DIMGUI_DISABLE_OBSOLETE_KEYIO
+)
+
fm_run_hook(fm-userconfig-src)
include_directories(.)