summaryrefslogtreecommitdiffhomepage
path: root/demangle/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-08-30 07:14:22 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-08-30 18:22:56 +0200
commit5092df19372bd6957bd43649da43add30777212d (patch)
treebfc20215881a8e8699739069dab898b95dfd3ec6 /demangle/CMakeLists.txt
parentaf6ca21ed0f2715aad0b2ae80d200589b5e31089 (diff)
kill demangle
Diffstat (limited to 'demangle/CMakeLists.txt')
-rw-r--r--demangle/CMakeLists.txt39
1 files changed, 0 insertions, 39 deletions
diff --git a/demangle/CMakeLists.txt b/demangle/CMakeLists.txt
deleted file mode 100644
index ce3222a4..00000000
--- a/demangle/CMakeLists.txt
+++ /dev/null
@@ -1,39 +0,0 @@
-cmake_minimum_required(VERSION 3.18 FATAL_ERROR)
-project(demumble CXX)
-
-set(CMAKE_CXX_VISIBILITY_PRESET hidden)
-set(CMAKE_VISIBILITY_INLINES_HIDDEN ON)
-set(CMAKE_POSITION_INDEPENDENT_CODE TRUE)
-set(CMAKE_CXX_STANDARD 23)
-set(CMAKE_CXX_STANDARD_DEFAULT 23)
-set(CMAKE_CXX_STANDARD_REQUIRED TRUE)
-set(CMAKE_CXX_EXTENSIONS FALSE)
-
-if (NOT MSVC)
- add_compile_options(-Wall -fno-exceptions -fno-rtti)
- # 10.9 chosen somewhat arbitrary; it's the first target where clang defaults
- # to libc++ and ld64 defaults to stripping __TEXT,__eh_frame.
- if (APPLE)
- add_compile_options(-mmacosx-version-min=10.9)
- else()
- add_compile_options(-fno-plt)
- endif()
- add_compile_options(-Wno-error -Wno-sign-conversion -Wno-unused -Wno-unused-parameter)
- if(CMAKE_CXX_COMPILER_ID MATCHES "Clang$")
- add_compile_options(-Wno-shorten-64-to-32 -Wno-implicit-int-conversion -Wno-class-varargs -Wno-extra-semi-stmt)
- endif()
-else()
- add_compile_options(-Zc:inline -permissive- -GR-)
- add_compile_options(-wd4100 -wd4244 -wd4267)
- add_definitions(-D_HAS_EXCEPTIONS=0 -DNOMINMAX -D_USE_MATH_DEFINES=1)
- add_definitions(-D_CRT_SECURE_NO_WARNINGS) # The LLVM build sets this.
-endif()
-
-include_directories(SYSTEM third_party/llvm/include)
-add_library(demumble STATIC
- third_party/llvm/lib/Demangle/Demangle.cpp
- third_party/llvm/lib/Demangle/ItaniumDemangle.cpp
- third_party/llvm/lib/Demangle/MicrosoftDemangle.cpp
- third_party/llvm/lib/Demangle/MicrosoftDemangleNodes.cpp
- demangle.cpp)
-target_link_libraries(demumble PUBLIC Corrade::Containers)