summaryrefslogtreecommitdiffhomepage
path: root/draw/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-11-12 13:43:34 +0100
committerStanislaw Halik <sthalik@misaki.pl>2022-11-12 17:47:30 +0100
commitd481edb3619e251285c238c05f47a121ecd96df7 (patch)
treeff81314fbcb75ad1272285b827b6c2e8f3ac694e /draw/CMakeLists.txt
parent58bf715b7932be0e6e611cbde0c6aa6fe82a6f70 (diff)
cmake: add targets for loader, serialize, draw
Diffstat (limited to 'draw/CMakeLists.txt')
-rw-r--r--draw/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/draw/CMakeLists.txt b/draw/CMakeLists.txt
new file mode 100644
index 00000000..ded948b8
--- /dev/null
+++ b/draw/CMakeLists.txt
@@ -0,0 +1,11 @@
+set(self floormat-draw)
+file(GLOB sources "*.cpp" CONFIGURE_ARGS)
+add_library(${self} STATIC "${sources}")
+target_link_libraries(
+ ${self} PUBLIC
+ floormat
+ Magnum::GL
+)
+if(FLOORMAT_PRECOMPILED-HEADERS)
+ target_precompile_headers(${self} PRIVATE precomp.hpp)
+endif()