summaryrefslogtreecommitdiffhomepage
path: root/editor/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-11-22 22:45:48 +0100
committerStanislaw Halik <sthalik@misaki.pl>2022-11-22 22:45:48 +0100
commit628940923846b9f3341369def9b262c1d0f70605 (patch)
tree48c3b5d5d186dc9e362134d575fd23cb92ca1490 /editor/CMakeLists.txt
parent7ce9e7551738c6e8676b7dc513b12c2bf5ec60f7 (diff)
add icon
Diffstat (limited to 'editor/CMakeLists.txt')
-rw-r--r--editor/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/editor/CMakeLists.txt b/editor/CMakeLists.txt
index 2b42e15d..30b6ce5a 100644
--- a/editor/CMakeLists.txt
+++ b/editor/CMakeLists.txt
@@ -13,6 +13,9 @@ link_libraries(MagnumIntegration::ImGui fmt::fmt)
link_libraries(floormat-main floormat-loader floormat-serialize)
add_executable(${self} "${sources}" "${res}")
+if(WIN32)
+ target_sources(${self} PRIVATE "../main/floormat.rc")
+endif()
if(FLOORMAT_PRECOMPILED-HEADERS)
target_precompile_headers(${self} PRIVATE precomp.hpp)