summaryrefslogtreecommitdiffhomepage
path: root/editor/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-11-12 13:43:34 +0100
committerStanislaw Halik <sthalik@misaki.pl>2022-11-12 17:47:30 +0100
commitd481edb3619e251285c238c05f47a121ecd96df7 (patch)
treeff81314fbcb75ad1272285b827b6c2e8f3ac694e /editor/CMakeLists.txt
parent58bf715b7932be0e6e611cbde0c6aa6fe82a6f70 (diff)
cmake: add targets for loader, serialize, draw
Diffstat (limited to 'editor/CMakeLists.txt')
-rw-r--r--editor/CMakeLists.txt10
1 files changed, 3 insertions, 7 deletions
diff --git a/editor/CMakeLists.txt b/editor/CMakeLists.txt
index b420aa9c..2b42e15d 100644
--- a/editor/CMakeLists.txt
+++ b/editor/CMakeLists.txt
@@ -1,6 +1,6 @@
-set(self ${PROJECT_NAME}-editor)
+set(self floormat-editor)
-file(GLOB sources "*.cpp" "../loader/*.cpp" CONFIGURE_ARGS)
+file(GLOB sources "*.cpp" CONFIGURE_ARGS)
corrade_add_resource(res "../resources.conf")
if(MSVC)
@@ -9,14 +9,10 @@ else()
set_property(SOURCE "${res}" APPEND PROPERTY COMPILE_OPTIONS "-w")
endif()
-if(WIN32)
- link_libraries(ntdll)
-endif()
-
link_libraries(MagnumIntegration::ImGui fmt::fmt)
+link_libraries(floormat-main floormat-loader floormat-serialize)
add_executable(${self} "${sources}" "${res}")
-target_link_libraries(${self} ${PROJECT_NAME}-main)
if(FLOORMAT_PRECOMPILED-HEADERS)
target_precompile_headers(${self} PRIVATE precomp.hpp)