summaryrefslogtreecommitdiffhomepage
path: root/main/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-23 10:12:00 +0200
committerStanislaw Halik <sthalik@misaki.pl>2022-10-23 10:12:00 +0200
commit692e5626d62c6ac652d554e5df4fd4b023c1acda (patch)
tree5f9626452af0dc7cb64ed4b1a053e8a6b518dce4 /main/CMakeLists.txt
parentdb2a8661d5dc8cecb4fea80d5cfec237af67ea24 (diff)
add static library for main/
Diffstat (limited to 'main/CMakeLists.txt')
-rw-r--r--main/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/CMakeLists.txt b/main/CMakeLists.txt
index eba2e95b..e567dee2 100644
--- a/main/CMakeLists.txt
+++ b/main/CMakeLists.txt
@@ -11,7 +11,9 @@ if(MSVC)
else()
set_property(SOURCE "${res}" APPEND PROPERTY COMPILE_OPTIONS "-w")
endif()
-add_executable(${self} "${sources}" "${res}")
+add_library(${self}-lib STATIC "${sources}")
+add_executable(${self} "${res}")
+target_link_libraries(${self} ${self}-lib)
set_property(TARGET ${self} PROPERTY OUTPUT_NAME "${PROJECT_NAME}")
install(TARGETS ${self} RUNTIME DESTINATION bin)