summaryrefslogtreecommitdiffhomepage
path: root/main/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-04-10 08:52:32 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-04-10 10:35:00 +0200
commitfdcff54e1d845343cdfe39040aac6f7ff9b4163a (patch)
treedb8de10a96b8022f43761c74a2d58453e3380d93 /main/CMakeLists.txt
parent8c867fac69fa9da0370000fa170cad1e22702ce5 (diff)
cmake: remove precompiled headers
They were having problems including fmtlib and robin_map.
Diffstat (limited to 'main/CMakeLists.txt')
-rw-r--r--main/CMakeLists.txt14
1 files changed, 1 insertions, 13 deletions
diff --git a/main/CMakeLists.txt b/main/CMakeLists.txt
index 50e1bc91..fe32d1d5 100644
--- a/main/CMakeLists.txt
+++ b/main/CMakeLists.txt
@@ -8,17 +8,5 @@ target_link_libraries(${self} PUBLIC
Magnum::GL
Magnum::Trade
fmt::fmt
+ tsl::robin_map
)
-
-if(NOT SDL2_INCLUDE_DIRS)
- if(NOT TARGET SDL2::SDL2)
- find_package(SDL2 QUIET REQUIRED)
- else()
- get_target_property(SDL2_INCLUDE_DIRS SDL2::SDL2 INTERFACE_INCLUDE_DIRECTORIES)
- endif()
-endif()
-include_directories("${SDL2_INCLUDE_DIRS}")
-
-if(FLOORMAT_PRECOMPILED-HEADERS)
- target_precompile_headers(${self} PRIVATE precomp.hpp)
-endif()