summaryrefslogtreecommitdiffhomepage
path: root/serialize/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-12-02 03:53:23 +0100
committerStanislaw Halik <sthalik@misaki.pl>2022-12-02 03:53:23 +0100
commit9a0ac7c7fd06a60f0e61b88828eaa59c0ee30fdd (patch)
treed8166bea565e13e6337b4bd3dc2fb8be027d69b5 /serialize/CMakeLists.txt
parente76fae1b2f007efc58ef46ecc248d271676c6673 (diff)
serialize: work on recovering from corrupted saves
Diffstat (limited to 'serialize/CMakeLists.txt')
-rw-r--r--serialize/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/serialize/CMakeLists.txt b/serialize/CMakeLists.txt
index 501dc448..7b7efb76 100644
--- a/serialize/CMakeLists.txt
+++ b/serialize/CMakeLists.txt
@@ -5,14 +5,16 @@ target_link_libraries(
${self}_o PUBLIC
Magnum::Magnum
nlohmann_json::nlohmann_json
+ fmt::fmt
)
+
+if(MSVC)
+ add_compile_options(-EHsc)
+endif()
+
add_library(${self} STATIC dummy.cc)
target_link_libraries(${self} PUBLIC ${self}_o floormat-loader floormat)
if(FLOORMAT_PRECOMPILED-HEADERS)
target_precompile_headers(${self}_o PRIVATE precomp.hpp)
endif()
-
-if(MSVC)
- add_compile_options(-EHsc)
-endif()