summaryrefslogtreecommitdiffhomepage
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-06 09:49:23 +0200
committerStanislaw Halik <sthalik@misaki.pl>2022-10-06 09:57:50 +0200
commit89acc4653fe7ea3a76dd49711b3ac6b704ed509d (patch)
treedcff8947d840f50ee348e375aca311829dad2e7a /src/CMakeLists.txt
parent595c113b88dc1e81802b4b1381122f25c0eece74 (diff)
a
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 00000000..e443a9df
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(self ${PROJECT_NAME})
+file(GLOB sources "*.cpp" "../shaders/*.cpp" "../serialize/*.cpp" CONFIGURE_ARGS)
+add_library(${self} STATIC "${sources}")
+target_link_libraries(
+ ${self} PUBLIC
+ Magnum::GL
+ Magnum::Magnum
+ Magnum::Shaders
+ nlohmann_json::nlohmann_json
+)
+target_include_directories(${self} PRIVATE ${GLM_INCLUDE_DIRS})
+target_include_directories(${self} PRIVATE magnum-integration/src)