summaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-10-11 10:35:06 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-10-11 13:35:27 +0200
commitca4544f04cc67c296e58170e76203bc11519d988 (patch)
tree2dcbe936be206c4e7f95a28525fafff6f7340e5e /test/CMakeLists.txt
parent018755dab3d2a5bb0ead627b6ecad6735a9f0114 (diff)
add benchmark executable
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt15
1 files changed, 6 insertions, 9 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 0d713de5..f8048278 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -4,15 +4,12 @@ file(GLOB sources "*.cpp" CONFIGURE_ARGS)
file(MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/test")
add_library(${self}_o OBJECT "${sources}")
-target_link_libraries(${self}_o PUBLIC Magnum::GL Magnum::Trade nlohmann_json::nlohmann_json fmt::fmt tsl::robin_map)
-
-if(APPLE)
- target_link_libraries(${self}_o PUBLIC Magnum::WindowlessCglApplication)
-elseif(WIN32)
- target_link_libraries(${self}_o PUBLIC Magnum::WindowlessWglApplication ntdll)
-else()
- target_link_libraries(${self}_o PUBLIC Magnum::WindowlessGlxApplication)
-endif()
+target_link_libraries(${self}_o PUBLIC
+ ${floormat_headless-library}
+ Magnum::GL Magnum::Trade
+ nlohmann_json::nlohmann_json
+ fmt::fmt tsl::robin_map
+)
add_executable(${self} dummy.cc)
target_link_libraries(${self} ${self}_o floormat-serialize floormat)