summaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-10-17 00:12:27 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-10-17 00:12:27 +0200
commit07ae849c48de49b2644e78fa02fda63275104164 (patch)
tree1c4c5abc01648280d45f33a5b107b1dd36afa4a8 /test/CMakeLists.txt
parenta4a9c191018ad225d36665eaf33f9dbff27514c4 (diff)
cmake: fix constantly relinking
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index ab11d536..7609655d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -18,8 +18,7 @@ if (FLOORMAT_ASAN)
set_target_properties(${self} PROPERTIES OUTPUT_NAME "floormat-test-asan")
endif()
-install(TARGETS ${self} RUNTIME DESTINATION bin)
-fm_add_debug_info(${self})
+fm_add_install_executable(${self})
set(save-dir "${CMAKE_BINARY_DIR}/test/save")
file(REMOVE_RECURSE "${save-dir}")