summaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-06 18:24:20 +0200
committerStanislaw Halik <sthalik@misaki.pl>2022-10-06 18:24:20 +0200
commit84d091346a9fdf26f5dca2cc49a1c592f40fcd05 (patch)
tree700d5ada6e4f72f545e9019bb848c47e4483ec49 /test/CMakeLists.txt
parent906c4f794e02904325cd61124e41d8868e78d3fa (diff)
a
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2bec4a7c..ec7078cb 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,8 +1,11 @@
set(self "${PROJECT_NAME}-test")
file(GLOB sources "*.cpp" CONFIGURE_ARGS)
+file(MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/test")
+
link_libraries(${PROJECT_NAME})
link_libraries(Magnum::Application Magnum::Trade)
add_executable(${self} "${sources}" "../main/loader-impl.cpp")
install(TARGETS ${self} RUNTIME DESTINATION bin)
+