summaryrefslogtreecommitdiffhomepage
path: root/draw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'draw/CMakeLists.txt')
-rw-r--r--draw/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/draw/CMakeLists.txt b/draw/CMakeLists.txt
new file mode 100644
index 00000000..ded948b8
--- /dev/null
+++ b/draw/CMakeLists.txt
@@ -0,0 +1,11 @@
+set(self floormat-draw)
+file(GLOB sources "*.cpp" CONFIGURE_ARGS)
+add_library(${self} STATIC "${sources}")
+target_link_libraries(
+ ${self} PUBLIC
+ floormat
+ Magnum::GL
+)
+if(FLOORMAT_PRECOMPILED-HEADERS)
+ target_precompile_headers(${self} PRIVATE precomp.hpp)
+endif()