summaryrefslogtreecommitdiffhomepage
path: root/editor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'editor/CMakeLists.txt')
-rw-r--r--editor/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/editor/CMakeLists.txt b/editor/CMakeLists.txt
index 30b6ce5a..38db2a04 100644
--- a/editor/CMakeLists.txt
+++ b/editor/CMakeLists.txt
@@ -9,10 +9,12 @@ else()
set_property(SOURCE "${res}" APPEND PROPERTY COMPILE_OPTIONS "-w")
endif()
-link_libraries(MagnumIntegration::ImGui fmt::fmt)
-link_libraries(floormat-main floormat-loader floormat-serialize)
+add_library(${self}_o STATIC "${sources}")
+target_link_libraries(${self}_o PUBLIC MagnumIntegration::ImGui SDL2::SDL2 fmt::fmt nlohmann_json::nlohmann_json)
+
+add_executable(${self} "${res}")
+target_link_libraries(${self} PUBLIC ${self}_o floormat-main floormat-loader floormat-serialize)
-add_executable(${self} "${sources}" "${res}")
if(WIN32)
target_sources(${self} PRIVATE "../main/floormat.rc")
endif()