summaryrefslogtreecommitdiffhomepage
path: root/external/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/CMakeLists.txt')
-rw-r--r--external/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
index c7ed3725..8f5632d1 100644
--- a/external/CMakeLists.txt
+++ b/external/CMakeLists.txt
@@ -31,6 +31,10 @@ else()
endif()
if(FLOORMAT_SUBMODULE-DEPENDENCIES)
+ add_definitions(
+ -DIMGUI_DISABLE_OBSOLETE_FUNCTIONS
+ -DIMGUI_DISABLE_OBSOLETE_KEYIO
+ )
sets(STRING
SDL_INSTALL_CMAKEDIR "share/cmake/SDL2"
NLOHMANN_JSON_CONFIG_INSTALL_DIR "share/cmake/nlohmann_json"