summaryrefslogtreecommitdiffhomepage
path: root/external/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/CMakeLists.txt')
-rw-r--r--external/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
index 3b4110b7..6cf2ad2d 100644
--- a/external/CMakeLists.txt
+++ b/external/CMakeLists.txt
@@ -12,6 +12,15 @@ if(MSVC)
set_property(DIRECTORY APPEND PROPERTY STATIC_LIBRARY_OPTIONS
-IGNORE:4006 #warning LNK4006: main already defined in x.cpp.obj; second definition ignored
)
+ add_compile_options(
+ -wd4244 # warning C4244: 'argument': conversion from 'int' to 'float', possible loss of data
+ -wd4312 # warning C4312: 'reinterpret_cast': conversion from 'GLenum' to 'void *' of greater size
+ -wd4251 # warning C4251: 't::f': class 'x' needs to have dll-interface to be used by clients of class 'y'
+ -wd4456 # warning C4456: declaration of 'x' hides previous local declaration
+ -wd4457 # #warning C4457: declaration of 'name' hides function parameter
+ #-wd4530 # warning C4530: C++ exception handler used, but unwind semantics are not enabled. Specify /EHsc
+ -wd4244 # warning C4244: 'initializing': conversion from 'unsigned int' to '_Ty', possible loss of data
+ )
else()
add_compile_options(
-Wno-error
@@ -137,7 +146,7 @@ endif()
if(FLOORMAT_SUBMODULE-DEPENDENCIES)
if(MSVC)
- target_compile_options(CorradeTestSuite PRIVATE -EHsc)
+ target_compile_options(CorradeTestSuiteObjects PRIVATE -EHsc)
endif()
endif()