summaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 20b66a6d..e835c359 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -26,3 +26,9 @@ file(GLOB saves "save/*.dat" CONFIGURE_ARGS)
foreach(file ${saves})
configure_file("${file}" "${save-dir}" COPYONLY)
endforeach()
+
+if(NOT MSVC)
+ target_precompile_headers(${self}_o REUSE_FROM floormat)
+else()
+ target_precompile_headers(${self}_o PRIVATE ../src/precomp.hpp)
+endif()