summaryrefslogtreecommitdiffhomepage
path: root/eigen/demos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'eigen/demos/CMakeLists.txt')
-rw-r--r--eigen/demos/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/eigen/demos/CMakeLists.txt b/eigen/demos/CMakeLists.txt
new file mode 100644
index 0000000..b0d2edd
--- /dev/null
+++ b/eigen/demos/CMakeLists.txt
@@ -0,0 +1,13 @@
+project(EigenDemos)
+
+add_custom_target(demos)
+
+if(NOT EIGEN_TEST_NOQT)
+ find_package(Qt4)
+ if(QT4_FOUND)
+ add_subdirectory(mandelbrot)
+ add_subdirectory(opengl)
+ else(QT4_FOUND)
+ message(STATUS "Qt4 not found, so disabling the mandelbrot and opengl demos")
+ endif(QT4_FOUND)
+endif()