summaryrefslogtreecommitdiffhomepage
path: root/eigen/doc/special_examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'eigen/doc/special_examples/CMakeLists.txt')
-rw-r--r--eigen/doc/special_examples/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/eigen/doc/special_examples/CMakeLists.txt b/eigen/doc/special_examples/CMakeLists.txt
new file mode 100644
index 0000000..3ab75db
--- /dev/null
+++ b/eigen/doc/special_examples/CMakeLists.txt
@@ -0,0 +1,21 @@
+if(NOT EIGEN_TEST_NOQT)
+ find_package(Qt4)
+ if(QT4_FOUND)
+ include(${QT_USE_FILE})
+ endif()
+endif(NOT EIGEN_TEST_NOQT)
+
+if(QT4_FOUND)
+ add_executable(Tutorial_sparse_example Tutorial_sparse_example.cpp Tutorial_sparse_example_details.cpp)
+ target_link_libraries(Tutorial_sparse_example ${EIGEN_STANDARD_LIBRARIES_TO_LINK_TO} ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY})
+
+ add_custom_command(
+ TARGET Tutorial_sparse_example
+ POST_BUILD
+ COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_CURRENT_BINARY_DIR}/../html/
+ COMMAND Tutorial_sparse_example ARGS ${CMAKE_CURRENT_BINARY_DIR}/../html/Tutorial_sparse_example.jpeg
+ )
+
+ add_dependencies(all_examples Tutorial_sparse_example)
+endif(QT4_FOUND)
+