summaryrefslogtreecommitdiffhomepage
path: root/eigen/unsupported/Eigen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'eigen/unsupported/Eigen/CMakeLists.txt')
-rw-r--r--eigen/unsupported/Eigen/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/eigen/unsupported/Eigen/CMakeLists.txt b/eigen/unsupported/Eigen/CMakeLists.txt
new file mode 100644
index 0000000..e1fbf97
--- /dev/null
+++ b/eigen/unsupported/Eigen/CMakeLists.txt
@@ -0,0 +1,11 @@
+set(Eigen_HEADERS AdolcForward AlignedVector3 ArpackSupport AutoDiff BVH FFT IterativeSolvers KroneckerProduct LevenbergMarquardt
+ MatrixFunctions MoreVectorization MPRealSupport NonLinearOptimization NumericalDiff OpenGLSupport Polynomials
+ Skyline SparseExtra Splines
+ )
+
+install(FILES
+ ${Eigen_HEADERS}
+ DESTINATION ${INCLUDE_INSTALL_DIR}/unsupported/Eigen COMPONENT Devel
+ )
+
+add_subdirectory(src)