summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-07-18 01:52:51 +0200
committerStanislaw Halik <sthalik@misaki.pl>2015-07-18 01:53:44 +0200
commita0667e93d039451e80af646faa5008d27b78f85b (patch)
treebf850e4685e3595ee5fdb1a9b8704ee2876567bc /CMakeLists.txt
parentc17264187594d325030fac243b4bc8ed02e52358 (diff)
initial version of macosx bundle script
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8ce4378..1e9fd3c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -352,6 +352,13 @@ if(SDK_WINE_PREFIX)
endif()
endif()
+if(APPLE)
+ install(SCRIPT "
+execute_process(COMMAND /bin/sh \"\${CMAKE_SOURCE_DIR}/macosx/make-app-bundle.sh\"
+ \"\${CMAKE_SOURCE_DIR}/macosx\" \"\${CMAKE_INSTALL_PREFIX}\" \"\${CMAKE_BUILD_DIR}\" \"${OPENTRACK__COMMIT}\")
+")
+endif()
+
opentrack_library(opentrack-tracker-udp ftnoir_tracker_udp)
opentrack_library(opentrack-tracker-freepie-udp ftnoir_tracker_freepie-udp)