summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-04-09 11:29:36 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-04-09 11:29:36 +0200
commit5c2f5449e8eb8a3c6d564a16fc8e307996746c14 (patch)
tree7620ca12dbe844150409db8d22d93e858b517ce2 /CMakeLists.txt
parentb78ac5d6535794967d5104bbc265b5079d0ac6b2 (diff)
Fix SimConnect (thanks Wim)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54bb79fd..5c41f652 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -203,7 +203,6 @@ if(NOT SDK_FACEAPI_ONLY)
QT4_WRAP_UI(ftnoir-proto-win32-mouse-uih ${ftnoir-proto-win32-mouse-ui})
QT4_ADD_RESOURCES(ftnoir-proto-win32-mouse-rcc ${ftnoir-proto-win32-mouse-rc})
-# TODO manifest problems :(
file(GLOB ftnoir-proto-simconnect-c "ftnoir_protocol_sc/*.cpp")
file(GLOB ftnoir-proto-simconnect-h "ftnoir_protocol_sc/*.h")
QT4_WRAP_CPP(ftnoir-proto-simconnect-moc ${ftnoir-proto-simconnect-h})
@@ -344,6 +343,9 @@ endif()
if(SDK_FSUIPC)
add_library(ftnoir-proto-fsuipc SHARED ${ftnoir-proto-fsuipc-c} ${ftnoir-proto-fsuipc-moc} ${ftnoir-proto-fsuipc-uih} ${ftnoir-proto-fsuipc-rcc})
target_link_libraries(ftnoir-proto-fsuipc ${MY_QT_LIBS} "${SDK_FSUIPC}/FSUIPC_User.lib")
+ if(MSVC)
+ set_target_properties(ftnoir-proto-fsuipc PROPERTIES LINK_FLAGS "/NODEFAULTLIB:libc")
+ endif()
endif()
if(SDK_SIMCONNECT)