summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2015-10-06 05:33:29 +0200
committerStanislaw Halik <sthalik@misaki.pl>2015-10-06 05:33:29 +0200
commit2b143a2cea018f6c62800fcb931cc950853728c7 (patch)
tree049f3a599ad760d5ca3cd1b1aeba0ef7d8ab37cc /CMakeLists.txt
parent0f7a4ba62369a42cf6b513ce0fa59d117551f0ed (diff)
un-bitrot installer support
Issue: #229
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6266ef51..67064d76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,8 @@ if(GIT_FOUND)
git_describe(OPENTRACK__COMMIT --tags --always)
endif()
+file(WRITE ${CMAKE_BINARY_DIR}/opentrack-version.h "#define OPENTRACK_VERSION \"${OPENTRACK__COMMIT}\"")
+
SET(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
SET(CMAKE_SKIP_INSTALL_RPATH FALSE)