summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2013-10-05 12:52:04 +0200
committerStanislaw Halik <sthalik@misaki.pl>2013-10-05 12:52:04 +0200
commit011c62ee59d9675095d40dee5079c91348959e91 (patch)
tree33e48d23d49c516356de6d8f0b3be017e0602367 /CMakeLists.txt
parentee843add4063931d8a0331eba3d60c8a579d0661 (diff)
add recenter spring cache option for Rift
Signed-off-by: Stanislaw Halik <sthalik@misaki.pl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ffb1c384..8ae29e4e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,10 +22,15 @@ endif()
IF(WIN32)
SET(SDK_SM_FACEAPI_PATH "" CACHE PATH "SeeingMachines FaceAPI SDK path")
SET(SDK_RIFT "" CACHE PATH "libOVR path")
+ SET(SDK_RIFT_RECENTRE_SPRING TRUE CACHE BOOL "recenter yaw aggressively")
SET(SDK_HYDRA "" CACHE PATH "libSixense path")
SET(SDK_VJOY "" CACHE PATH "VJoy SDK path")
ENDIF()
+if(SDK_RIFT_RECENTRE_SPRING)
+ add_definitions(-DOPENTRACK_RIFT_RECENTRE_SPRING)
+endif()
+
file(GLOB opentrack-faceapi-wrapper-c "faceapi/*.cpp")
include_directories(${CMAKE_SOURCE_DIR})