summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2016-09-11 08:32:15 +0200
committerStanislaw Halik <sthalik@misaki.pl>2016-09-11 08:32:15 +0200
commit2805768229898fa3802ceb6ef5585c2c0b973759 (patch)
tree13358009d9947d2b0daf23ce2f9a506a0d78a3ec /CMakeLists.txt
parentf6d0fa8ad07739b5c2994e51e3d26a51c874f13f (diff)
cmake: add mrproper target
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2353d70..741d0c0d 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,8 +5,8 @@ include(opentrack-build)
project(opentrack C CXX)
cmake_minimum_required(VERSION 2.8.11)
-include(opentrack-hier)
include(opentrack-word-size)
+include(opentrack-hier)
include(opentrack-policy)
include(opentrack-qt)
include(opentrack-platform)
@@ -14,6 +14,8 @@ include(opentrack-boilerplate)
include(opentrack-version)
include(opentrack-install)
+add_custom_target(mrproper COMMAND cmake -P "${CMAKE_SOURCE_DIR}/cmake/opentrack-clean-build-directory.cmake" WORKING_DIRECTORY "${CMAKE_BINARY_DIR}")
+
set(C CMakeLists.txt)
file(GLOB opentrack-subprojects
"tracker-*/${C}"